import re
regex = re.compile(r"^(\[[0-9]*]:)(.*)\r?\n?", flags=re.MULTILINE)
test_str = ("this is a [link][1]\n"
"[1]: http://example.com\n"
"and this is a [good website][2] in my opinion\n"
"[2]: http://goodwebsite.com\n"
"[3]: http://example.com/fsadf.jpg\n"
"[![this is a photo][3]][3]\n"
"and there is some text hare ..!")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)