package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\[[0-9]*]:)(.*)\r?\n?`)
var str = `this is a [link][1]
[1]: http://example.com
and this is a [good website][2] in my opinion
[2]: http://goodwebsite.com
[3]: http://example.com/fsadf.jpg
[![this is a photo][3]][3]
and there is some text hare ..!`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}