$re = '/^(\[[0-9]*]:)(.*)\r?\n?/m';
$str = 'this is a [link][1]
[1]: http://example.com
and this is a [good website][2] in my opinion
[2]: http://goodwebsite.com
[3]: http://example.com/fsadf.jpg
[![this is a photo][3]][3]
and there is some text hare ..!';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;