import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\[[0-9]*]:)(.*)\\r?\\n?";
final String string = "this is a [link][1]\n"
+ "[1]: http://example.com\n"
+ "and this is a [good website][2] in my opinion\n"
+ "[2]: http://goodwebsite.com\n"
+ "[3]: http://example.com/fsadf.jpg\n"
+ "[![this is a photo][3]][3]\n"
+ "and there is some text hare ..!";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}