#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:sandwich|toastie)(?:(?!(?:ham|cheese|pickle|\w\. +|(?:\r?\n|\r))).){1,100}(?:ham|cheese|pickle)"
Local $sString = "Victorians enjoyed a good sandwich after work. They also enjoyed cheese rolling. sandwich test" & @CRLF & _
" new line here" & @CRLF & _
"" & @CRLF & _
"test pickle" & @CRLF & _
"" & @CRLF & _
"Andy sat down to enjoy his sandwich which, unusally for him, was ham filled with delicious ham" & @CRLF & _
"" & @CRLF & _
"ham" & @CRLF & _
"" & @CRLF & _
"test" & @CRLF & _
"" & @CRLF & _
"cheese" & @CRLF & _
"" & @CRLF & _
"This is a sandwich with. ham or cheese."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")