import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:sandwich|toastie)(?:(?!(?:ham|cheese|pickle|\\w\\. +|(?:\\r?\\n|\\r))).){1,100}(?:ham|cheese|pickle)";
final String string = "Victorians enjoyed a good sandwich after work. They also enjoyed cheese rolling. sandwich test\n"
+ " new line here\n\n"
+ "test pickle\n\n"
+ "Andy sat down to enjoy his sandwich which, unusally for him, was ham filled with delicious ham\n\n"
+ "ham\n\n"
+ "test\n\n"
+ "cheese\n\n"
+ "This is a sandwich with. ham or cheese.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}