import re
regex = re.compile(r"(?:sandwich|toastie)(?:(?!(?:ham|cheese|pickle|\w\. +|(?:\r?\n|\r))).){1,100}(?:ham|cheese|pickle)", flags=re.MULTILINE)
test_str = ("Victorians enjoyed a good sandwich after work. They also enjoyed cheese rolling. sandwich test\n"
" new line here\n\n"
"test pickle\n\n"
"Andy sat down to enjoy his sandwich which, unusally for him, was ham filled with delicious ham\n\n"
"ham\n\n"
"test\n\n"
"cheese\n\n"
"This is a sandwich with. ham or cheese.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")