using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:sandwich|toastie)(?:(?!(?:ham|cheese|pickle|\w\. +|(?:\r?\n|\r))).){1,100}(?:ham|cheese|pickle)";
string input = @"Victorians enjoyed a good sandwich after work. They also enjoyed cheese rolling. sandwich test
new line here
test pickle
Andy sat down to enjoy his sandwich which, unusally for him, was ham filled with delicious ham
ham
test
cheese
This is a sandwich with. ham or cheese.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}