const regex = /(?:sandwich|toastie)(?:(?!(?:ham|cheese|pickle|\w\. +|(?:\r?\n|\r))).){1,100}(?:ham|cheese|pickle)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:sandwich|toastie)(?:(?!(?:ham|cheese|pickle|\\w\\. +|(?:\\r?\\n|\\r))).){1,100}(?:ham|cheese|pickle)', 'gm')
const str = `Victorians enjoyed a good sandwich after work. They also enjoyed cheese rolling. sandwich test
new line here
test pickle
Andy sat down to enjoy his sandwich which, unusally for him, was ham filled with delicious ham
ham
test
cheese
This is a sandwich with. ham or cheese.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}