re = /(?:sandwich|toastie)(?:(?!(?:ham|cheese|pickle|\w\. +|(?:\r?\n|\r))).){1,100}(?:ham|cheese|pickle)/m
str = 'Victorians enjoyed a good sandwich after work. They also enjoyed cheese rolling. sandwich test
new line here
test pickle
Andy sat down to enjoy his sandwich which, unusally for him, was ham filled with delicious ham
ham
test
cheese
This is a sandwich with. ham or cheese.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end