using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*\$inline\((.*)\).*$";
string substitution = @"\1";
string input = @"""Ez itt egy teszt szöveg $inline(filepath) és itt folytatódik a szöveg""
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}