use strict;
my $str = '"Ez itt egy teszt szöveg $inline(filepath) és itt folytatódik a szöveg"
';
my $regex = qr/^.*\$inline\((.*)\).*$/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";