re = /^.*\$inline\((.*)\).*$/m
str = '"Ez itt egy teszt szöveg $inline(filepath) és itt folytatódik a szöveg"
'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result