import re
regex = re.compile(r"^.*\$inline\((.*)\).*$", flags=re.MULTILINE)
test_str = ("\"Ez itt egy teszt szöveg $inline(filepath) és itt folytatódik a szöveg\"\n\n")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)