const regex = /^.*\$inline\((.*)\).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*\\$inline\\((.*)\\).*$', 'gm')
const str = `"Ez itt egy teszt szöveg \$inline(filepath) és itt folytatódik a szöveg"
`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);