package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`~\/home\/([A-Za-z_0-9-]+)$`)
var str = []byte(`172.168.255.0:80/home/hiii
`)
var substitution = []byte("")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}