const regex = /~\/home\/([A-Za-z_0-9-]+)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('~\\\/home\\\/([A-Za-z_0-9-]+)$', '')
const str = `172.168.255.0:80/home/hiii
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);