$re = '/~\/home\/([A-Za-z_0-9-]+)$/';
$str = '172.168.255.0:80/home/hiii
';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;