# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<(h\d)>.*?<\\/\2>)[\r\n]([^\r\n<]+)/\1\3/;t' <<< "<h1>test</h1>fdvsfdsfdsfdsfdvsbfdsvf"