use strict;
my $str = '<h1>test</h1>fdvsfdsfdsfdsfdvsbfdsvf';
my $regex = qr/(<(h\d)>.*?<\/\2>)[\r\n]([^\r\n<]+)/p;
my $subst = '\\1\\3';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";