$re = '/(<(h\d)>.*?<\/\2>)[\r\n]([^\r\n<]+)/';
$str = '<h1>test</h1>fdvsfdsfdsfdsfdvsbfdsvf';
$subst = "\1\3";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;