#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(<(h\d)>.*?<\/\2>)[\r\n]([^\r\n<]+)"
Local $sString = "<h1>test</h1>fdvsfdsfdsfdsfdvsbfdsvf"
Local $sSubst = "\1\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)