re = /(<(h\d)>.*?<\/\2>)[\r\n]([^\r\n<]+)/
str = '<h1>test</h1>fdvsfdsfdsfdsfdvsbfdsvf'
subst = '\\1\\3'
result = str.sub(re, subst)
# Print the result of the substitution
puts result