import Foundation
let pattern = #"(<(h\d)>.*?<\/\2>)[\r\n]([^\r\n<]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<h1>test</h1>fdvsfdsfdsfdsfdvsbfdsvf"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\3"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}