using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<(h\d)>.*?<\/\2>)[\r\n]([^\r\n<]+)";
string substitution = @"\1\3";
string input = @"<h1>test</h1>fdvsfdsfdsfdsfdvsbfdsvf";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}