#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xX)(?:" & @CRLF & _
" .?\n+ |" & @CRLF & _
" [[:alnum:]_](?=[^[:alnum:]_\s]) |" & @CRLF & _
" [^[:alnum:]_\s](?=[[:alnum:]_]) |" & @CRLF & _
" [^\S\n](?=[\S\n]) |" & @CRLF & _
")" & @CRLF & _
"(" & @CRLF & _
"(?:" & @CRLF & _
" [[:alnum:]_]+ |" & @CRLF & _
" [^[:alnum:]_\s]+ |" & @CRLF & _
")" & @CRLF & _
"[^\S\n]*" & @CRLF & _
")"
Local $sString = "w asdf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")