using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:
.?\n+ |
[[:alnum:]_](?=[^[:alnum:]_\s]) |
[^[:alnum:]_\s](?=[[:alnum:]_]) |
[^\S\n](?=[\S\n]) |
)
(
(?:
[[:alnum:]_]+ |
[^[:alnum:]_\s]+ |
)
[^\S\n]*
)";
string input = @"w asdf";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}