// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)(?:
.?\n+ |
[[:alnum:]_](?=[^[:alnum:]_\s]) |
[^[:alnum:]_\s](?=[[:alnum:]_]) |
[^\S\n](?=[\S\n]) |
)
(
(?:
[[:alnum:]_]+ |
[^[:alnum:]_\s]+ |
)
[^\S\n]*
)").unwrap();
let string = "w asdf";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}