package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:https?:)?\/\/(?:(?:www\.)?youtube\.com|youtu\.be)\/(?:(?:watch\?v=|user|v\/|embed\/))?([a-zA-Z0-9]+)`)
var str = `https://www.youtube.com/watch?v=fxIgkgBbpQg
https://youtube.com/watch?v=fxIgkgBbpQg
https://youtu.be/fxIgkgBbpQg
http://www.youtube.com/watch?v=fxIgkgBbpQg
http://youtube.com/watch?v=fxIgkgBbpQg
http://youtu.be/fxIgkgBbpQg
//www.youtube.com/watch?v=fxIgkgBbpQg
//youtube.com/watch?v=fxIgkgBbpQg
//youtu.be/fxIgkgBbpQg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}