import re
regex = re.compile(r"^(?:https?:)?\/\/(?:(?:www\.)?youtube\.com|youtu\.be)\/(?:(?:watch\?v=|user|v\/|embed\/))?([a-zA-Z0-9]+)", flags=re.MULTILINE)
test_str = ("https://www.youtube.com/watch?v=fxIgkgBbpQg\n"
"https://youtube.com/watch?v=fxIgkgBbpQg\n"
"https://youtu.be/fxIgkgBbpQg\n"
"http://www.youtube.com/watch?v=fxIgkgBbpQg\n"
"http://youtube.com/watch?v=fxIgkgBbpQg\n"
"http://youtu.be/fxIgkgBbpQg\n"
"//www.youtube.com/watch?v=fxIgkgBbpQg\n"
"//youtube.com/watch?v=fxIgkgBbpQg\n"
"//youtu.be/fxIgkgBbpQg")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")