$re = '/^(?:https?:)?\/\/(?:(?:www\.)?youtube\.com|youtu\.be)\/(?:(?:watch\?v=|user|v\/|embed\/))?([a-zA-Z0-9]+)/m';
$str = 'https://www.youtube.com/watch?v=fxIgkgBbpQg
https://youtube.com/watch?v=fxIgkgBbpQg
https://youtu.be/fxIgkgBbpQg
http://www.youtube.com/watch?v=fxIgkgBbpQg
http://youtube.com/watch?v=fxIgkgBbpQg
http://youtu.be/fxIgkgBbpQg
//www.youtube.com/watch?v=fxIgkgBbpQg
//youtube.com/watch?v=fxIgkgBbpQg
//youtu.be/fxIgkgBbpQg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);