import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:https?:)?\\/\\/(?:(?:www\\.)?youtube\\.com|youtu\\.be)\\/(?:(?:watch\\?v=|user|v\\/|embed\\/))?([a-zA-Z0-9]+)";
final String string = "https://www.youtube.com/watch?v=fxIgkgBbpQg\n"
+ "https://youtube.com/watch?v=fxIgkgBbpQg\n"
+ "https://youtu.be/fxIgkgBbpQg\n"
+ "http://www.youtube.com/watch?v=fxIgkgBbpQg\n"
+ "http://youtube.com/watch?v=fxIgkgBbpQg\n"
+ "http://youtu.be/fxIgkgBbpQg\n"
+ "//www.youtube.com/watch?v=fxIgkgBbpQg\n"
+ "//youtube.com/watch?v=fxIgkgBbpQg\n"
+ "//youtu.be/fxIgkgBbpQg";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}