#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([[:space:]])(vais|vas|va|allons|allez|vont)([[:space:]])([^\Qchez\E][^\Qassez\E][[:alpha:]]*)(z)([[:space:]]|[[:punct:]])"
Local $sString = "Je vais allez à Rome." & @CRLF & _
"Il va trouvez du boulot." & @CRLF & _
"Helen, va cherchez le kit de secours." & @CRLF & _
"Je vais passez de bonnes vacances." & @CRLF & _
"Ça va allez?" & @CRLF & _
"" & @CRLF & _
"Tu vas donner du travail." & @CRLF & _
"Il va aller chez Zara." & @CRLF & _
"J'en avais assez." & @CRLF & _
"Vous allez chez Lucie." & @CRLF & _
"Tout ça va assez mal." & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")