// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([[:space:]])(vais|vas|va|allons|allez|vont)([[:space:]])([^\Qchez\E][^\Qassez\E][[:alpha:]]*)(z)([[:space:]]|[[:punct:]])").unwrap();
let string = "Je vais allez à Rome.
Il va trouvez du boulot.
Helen, va cherchez le kit de secours.
Je vais passez de bonnes vacances.
Ça va allez?
Tu vas donner du travail.
Il va aller chez Zara.
J'en avais assez.
Vous allez chez Lucie.
Tout ça va assez mal.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}