# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([[:space:]])(vais|vas|va|allons|allez|vont)([[:space:]])([^\Qchez\E][^\Qassez\E][[:alpha:]]*)(z)([[:space:]]|[[:punct:]])"
test_str = ("Je vais allez à Rome.\n"
"Il va trouvez du boulot.\n"
"Helen, va cherchez le kit de secours.\n"
"Je vais passez de bonnes vacances.\n"
"Ça va allez?\n\n"
"Tu vas donner du travail.\n"
"Il va aller chez Zara.\n"
"J'en avais assez.\n"
"Vous allez chez Lucie.\n"
"Tout ça va assez mal.\n\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.