re = /([[:space:]])(vais|vas|va|allons|allez|vont)([[:space:]])([^\Qchez\E][^\Qassez\E][[:alpha:]]*)(z)([[:space:]]|[[:punct:]])/
str = 'Je vais allez à Rome.
Il va trouvez du boulot.
Helen, va cherchez le kit de secours.
Je vais passez de bonnes vacances.
Ça va allez?
Tu vas donner du travail.
Il va aller chez Zara.
J\'en avais assez.
Vous allez chez Lucie.
Tout ça va assez mal.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end