const regex = /([[:space:]])(vais|vas|va|allons|allez|vont)([[:space:]])([^\Qchez\E][^\Qassez\E][[:alpha:]]*)(z)([[:space:]]|[[:punct:]])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([[:space:]])(vais|vas|va|allons|allez|vont)([[:space:]])([^\\Qchez\\E][^\\Qassez\\E][[:alpha:]]*)(z)([[:space:]]|[[:punct:]])', 'g')
const str = `Je vais allez à Rome.
Il va trouvez du boulot.
Helen, va cherchez le kit de secours.
Je vais passez de bonnes vacances.
Ça va allez?
Tu vas donner du travail.
Il va aller chez Zara.
J'en avais assez.
Vous allez chez Lucie.
Tout ça va assez mal.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}