use strict;
my $str = 'Je vais allez à Rome.
Il va trouvez du boulot.
Helen, va cherchez le kit de secours.
Je vais passez de bonnes vacances.
Ça va allez?
Tu vas donner du travail.
Il va aller chez Zara.
J\'en avais assez.
Vous allez chez Lucie.
Tout ça va assez mal.
';
my $regex = qr/([[:space:]])(vais|vas|va|allons|allez|vont)([[:space:]])([^\Qchez\E][^\Qassez\E][[:alpha:]]*)(z)([[:space:]]|[[:punct:]])/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}