import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([[:space:]])(vais|vas|va|allons|allez|vont)([[:space:]])([^\\Qchez\\E][^\\Qassez\\E][[:alpha:]]*)(z)([[:space:]]|[[:punct:]])";
final String string = "Je vais allez à Rome.\n"
+ "Il va trouvez du boulot.\n"
+ "Helen, va cherchez le kit de secours.\n"
+ "Je vais passez de bonnes vacances.\n"
+ "Ça va allez?\n\n"
+ "Tu vas donner du travail.\n"
+ "Il va aller chez Zara.\n"
+ "J'en avais assez.\n"
+ "Vous allez chez Lucie.\n"
+ "Tout ça va assez mal.\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}