const regex = /(@\{)\s*(\S+)\s*(?=})/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(@\\{)\\s*(\\S+)\\s*(?=})', 'gmi')
const str = `<div><b>@{ firstname } @{lastname}</b>,@{ gender }</div>`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);