use strict;
my $str = '<div><b>@{ firstname } @{lastname}</b>,@{ gender }</div>';
my $regex = qr/(@\{)\s*(\S+)\s*(?=})/mip;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";