import re
regex = re.compile(r"(@\{)\s*(\S+)\s*(?=})", flags=re.MULTILINE | re.IGNORECASE)
test_str = "<div><b>@{ firstname } @{lastname}</b>,@{ gender }</div>"
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)