# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(String|int|char|boolean|double)\s+(?!(?:String|int|char|boolean|double)\b)[a-zA-Z]+//g;t' <<< "char myDog
char char
boolean IsitTrue
boolean char
int intro
"