use strict;
my $str = 'char myDog
char char
boolean IsitTrue
boolean char
int intro
';
my $regex = qr/(String|int|char|boolean|double)\s+(?!(?:String|int|char|boolean|double)\b)[a-zA-Z]+/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";