#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(String|int|char|boolean|double)\s+(?!(?:String|int|char|boolean|double)\b)[a-zA-Z]+"
Local $sString = "char myDog" & @CRLF & _
"char char" & @CRLF & _
"boolean IsitTrue" & @CRLF & _
"boolean char" & @CRLF & _
"int intro" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)