$re = '/(String|int|char|boolean|double)\s+(?!(?:String|int|char|boolean|double)\b)[a-zA-Z]+/';
$str = 'char myDog
char char
boolean IsitTrue
boolean char
int intro
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;