#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)<a(?!.*<a).+<\/a>"
Local $sString = "<div id="breadcrumbs">" & @CRLF & _
" <a href="/">Home</a>" & @CRLF & _
" <a href="/suppliers">Suppliers</a>" & @CRLF & _
" <button>This One i needed</button> " & @CRLF & _
" <span class="currentpage">Amrapali</span>" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")