$re = '/(?s)<a(?!.*<a).+<\/a>/';
$str = '<div id="breadcrumbs">
<a href="/">Home</a>
<a href="/suppliers">Suppliers</a>
<button>This One i needed</button>
<span class="currentpage">Amrapali</span>
</div>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);