re = /(?s)<a(?!.*<a).+<\/a>/
str = '<div id="breadcrumbs">
<a href="/">Home</a>
<a href="/suppliers">Suppliers</a>
<button>This One i needed</button>
<span class="currentpage">Amrapali</span>
</div>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end