import Foundation
let pattern = #"(?s)<a(?!.*<a).+<\/a>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<div id="breadcrumbs">
<a href="/">Home</a>
<a href="/suppliers">Suppliers</a>
<button>This One i needed</button>
<span class="currentpage">Amrapali</span>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}